Forumsee logo
Forumsee » Consumer Electronics » Home Audio & Video » Read message
RSS: Subscribe to RSS

18" ultimax no spl under 30hz. Something wrong with the driver?

DIY Speakers and Subs - www.avsforum.com
My setup

Full martysub with um18-22

Inuke 6000 dsp

Emotive xmc-1

Room around 30x45x20, that's counting all the open spaces, tiles as my floor.

1.So I finally decided to use ReW to measure my subwoofer and I am pretty disappointed. I basically get no spl under 30hz. I understand the room is pretty big but I thought I could at least get some decent spl from 30hz to 17hz.

2. I have my inuke 6k limiter set at 1200watts and HPF at 17hz. Will I damage my um18-22 and amp if the limiter light is constantly on?

3. I also noticed that sometimes when I increase the volume of my xmc-1, I hear a weird clicking noise, kinda like a gear is changing or something. Anybody know what's the problem?
Date: Jul 30, 2015   


Last videos:

When History repeats in Video
When History repeats in Video
Happy on SYFY
Happy on SYFY
apple fired a engineer
apple fired a engineer
How Sony TV's are made
How Sony TV's are made
Life Videos Youtube
Life Videos Youtube
Songs that ROCK--give us the vid
Songs that ROCK--give us the vid
New Dirac enabled Lexicon AVRs
New Dirac enabled Lexicon AVRs
Gotta respect CRTs
Gotta respect CRTs
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
About Forumsee · Contact · Privacy policy · Request content removal
production-frontend
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more