Forumsee logo
Forumsee » Consumer Electronics » Home Audio & Video » Read message
RSS: Subscribe to RSS

2009 Ford Explorer

Amplifiers / Head Units / Processors / Electrical - SSA Car Audio Forum - www.soundsolutionsaudio.com
I will try to post pics soon. The question is has anyone ever installed the big 3 on this model of a vehicle. 2009 Ford Explorer 4.6Lt? I have been looking at my electrical and there is ll kinds of run offs from the positive wire from battery. There are 2 that run from positive into the fuse box, and at least 2 more that split off into I haven't found where yet. Seem like a lot. My question is would it be OK to keep those running to where they are going and still run 0 gauge from Alt to battery using a bus bar or similar? Also with the ground question there are several split offs from the ground battery terminal to the chasey, should just through those on top of my 0 gauge ground? 

Thanks
Date: Jan 5, 2014   


Last videos:

When History repeats in Video
When History repeats in Video
Happy on SYFY
Happy on SYFY
apple fired a engineer
apple fired a engineer
How Sony TV's are made
How Sony TV's are made
Life Videos Youtube
Life Videos Youtube
Songs that ROCK--give us the vid
Songs that ROCK--give us the vid
New Dirac enabled Lexicon AVRs
New Dirac enabled Lexicon AVRs
Gotta respect CRTs
Gotta respect CRTs
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
About Forumsee · Contact · Privacy policy · Request content removal
production-frontend
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more