Forumsee logo
Forumsee » Consumer Electronics » Home Audio & Video » Read message
RSS: Subscribe to RSS

Need a little help with an old amp

Marantz Audio | Audiokarma Home Audio Stereo Discussion Forums - audiokarma.org
I have this Marantz PM700 I essentially got for free a few years ago. One channel was hosed on it, put new output and driver transistors in it. R766 &Q726 was shorted out and Q806 on the power board was dead. I recapped the power board, amps and tone boards. I have desoldered and checked darn near everything in this unit over the past couple weeks, cannot find the culprit. When you power it up, it draws excessive current and Q726 gets very hot. There must be a short somewhere as the rail voltages are about 8 volts low. It is actually good from a learning standpoint that I have been messing with this but I think I am at my wits end. I linked some hi res pics and posted a low res pic. If anyone has the inclination to lend some support, it would be much appreciated. I would have done more voltage measurements but that output transistor gets so hot so fast I don't want to fry it. So, I will do any requested measurements as to limit the time its on. Thanks!

Date: Jan 12, 2018   


Last videos:

When History repeats in Video
When History repeats in Video
Happy on SYFY
Happy on SYFY
apple fired a engineer
apple fired a engineer
How Sony TV's are made
How Sony TV's are made
Life Videos Youtube
Life Videos Youtube
Songs that ROCK--give us the vid
Songs that ROCK--give us the vid
New Dirac enabled Lexicon AVRs
New Dirac enabled Lexicon AVRs
Gotta respect CRTs
Gotta respect CRTs
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
About Forumsee · Contact · Privacy policy · Request content removal
production-frontend
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more