Forumsee logo
Forumsee » Consumer Electronics » Home Audio & Video » Read message
RSS: Subscribe to RSS

Amp and speakers - low volume, no bass

Receivers, Amps, and Processors - www.avsforum.com
Hi,

I recently purchased a Cambridge TOPAZ SR20, to be used with a set of speakers I already own. These are B&W DM305. I remember these being very loud with a lot of bass when connected to an Arcam Alpha 6 plus, which I no longer have.

Connecting the SR20 to the B&W speakers, the volume doesn’t seem very loud at all and there is little to no bass being produced. The sound is clear, although I do have to turn the volume up quite a bit. This happens with all inputs.

I’ve checked the specs of everything and to me they look compatible. Am I missing something or doing something wrong?

Thanks in advanced for any assistance.


Read responses in avsforum.com

Last videos:

The Innocents - Netflix Series
The Innocents - Netflix Series
Sacred Games Series - Netflix
Sacred Games Series - Netflix
Another out of box thought; Exciter Panel speakers ; Interesting
Another out of box thought; Exciter Panel speakers ; Interesting
Apparently there is a new Elac B6
Apparently there is a new Elac B6
Requiem on Netflix
Requiem on Netflix
Mute - Netflix
Mute - Netflix
Seven Seconds - Netflix
Seven Seconds - Netflix
CES 1980 - A Retro Look Back
CES 1980 - A Retro Look Back
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more