Forumsee logo
Forumsee » Consumer Electronics » Home Audio & Video » Read message
RSS: Subscribe to RSS

Help - killed both Cerwin Vega tweeters (or worse) with APM-200?

Speakers | Audiokarma Home Audio Stereo Discussion Forums - audiokarma.org
Fellow AK's,

We'll I bought and hooked up a used Realistic APM-200. I checked all connections, except I set the impedance incorrectly. Duh. I set it to 4ohms, not 8ohms.

I turned it on and didn't see a lot of movement on the meters, so I turned it up. The amp clicked off. I freaked out and realized my mistake. I changed the impedance to 8ohms (to match my Cerwin Vega VS-120's), and it all came back on.

BUT....now neither tweeter is now working. Mids and woofers are OK, but nothing on the tweeters. Is it possible to have blown BOTH tweeters with my ignorance? Is it possible I blew up a capacitor? I don't think I hurt the amp, right? It's still cranking away, but only on the mids and woofers.

Ugh....any help is appreciated.

 


Read responses in audiokarma.org

Last videos:

Sacred Games Series - Netflix
Sacred Games Series - Netflix
Another out of box thought; Exciter Panel speakers ; Interesting
Another out of box thought; Exciter Panel speakers ; Interesting
Apparently there is a new Elac B6
Apparently there is a new Elac B6
Requiem on Netflix
Requiem on Netflix
Mute - Netflix
Mute - Netflix
Seven Seconds - Netflix
Seven Seconds - Netflix
CES 1980 - A Retro Look Back
CES 1980 - A Retro Look Back
When History repeats in Video
When History repeats in Video
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more