Forumsee logo
Forumsee » Consumer Electronics » TVs » Read message
RSS: Subscribe to RSS

Motorola (HD dual tuner DVR) DCH6416

HDTV Technical - www.avsforum.com
I've been using Motorola DCH6416 a few months with no issues. Today it would not power on with remote or by pushing power button on unit. I unplugged it & after plugging back in it displayed 8888 a few seconds then 8888 was replaced with a small blue dot. TV will not power on while connected to unit but is fine when disconnected from it. I hate to lose all shows recorded on it but I'm assuming there are no other options since tv will not even operate while connected?? I have checked all connections, power cord, etc. Is it common for this dvr to have this issue? I figure if I take it to my cable provider they will replace it with another of the same model. Was wondering if this is common or I just got a defective unit.


Read responses in avsforum.com

Last videos:

CES 1980 - A Retro Look Back
CES 1980 - A Retro Look Back
When History repeats in Video
When History repeats in Video
Happy on SYFY
Happy on SYFY
apple fired a engineer
apple fired a engineer
How Sony TV's are made
How Sony TV's are made
Life Videos Youtube
Life Videos Youtube
Songs that ROCK--give us the vid
Songs that ROCK--give us the vid
New Dirac enabled Lexicon AVRs
New Dirac enabled Lexicon AVRs
Cars · 
Mobility · 
Hardware · 
Motorbikes · 
Travel · 
Boating · 
Aviation · 
production-frontend
About Forumsee · Contact · Privacy policy · Request content removal
We use cookies for navigation analysis and personalized advertisement. By using our site, you agree to our use of cookies.
Accept  ·  Learn more